Singularity - Elevated error rates appearing for certain API requests for the latests data – Incident details

Elevated error rates appearing for certain API requests for the latests data

Resolved
Major outage
Started 5 days agoLasted 2 days

Affected

Singularity API

Major outage from 11:55 AM to 2:00 PM, Operational from 2:00 PM to 2:30 PM, Major outage from 2:30 PM to 2:35 PM, Operational from 2:35 PM to 11:43 PM

3rd Party Data Sources

Operational from 11:55 AM to 2:35 PM, Degraded performance from 2:35 PM to 11:43 PM

EIA Data

Operational from 11:55 AM to 2:35 PM, Degraded performance from 2:35 PM to 11:43 PM

US ISOs

Operational from 11:55 AM to 2:35 PM, Degraded performance from 2:35 PM to 11:43 PM

BPA

Operational from 11:55 AM to 2:35 PM, Degraded performance from 2:35 PM to 11:43 PM

CAISO

Operational from 11:55 AM to 2:35 PM, Degraded performance from 2:35 PM to 11:43 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    API errors have resolved. The team is monitoring a backfill as missing data is being written to the database. We expect this to be resolved today.

  • Monitoring
    Monitoring

    The team has implemented a fix and are monitoring error rates as the system recovers.

  • Identified
    Identified

    The team has identified the issue and is actively working to resolve the issue.

  • Investigating
    Investigating
    We are currently investigating this incident.